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Agenda

Starting SPSS

Getting data into SPSS
Getting to know SPSS
Creating a histogram



1. Starting SPSS

1. Select SPSS 14.0
for Windows from the
Start Menu

b il S B T TR I T D

WWhat would vou like to do’?

3 Run the tutarial

() Type in data

) Fun an existing queny

2. Select the ESC key () Create new query uzsing D atabase Wizard
to bypass the opening

dialog box at right.

(%) Open an exizting data source

C:AProgram Files\SPS54Cars. zaw

CADOCUME ~1 enordmos  LOCALS ~ 15T empheqgl
C:ADocuments and Settings‘enordmosiMy Docum
C:ADocumentz and Settingshenordmoe’ by D ocum

% () Open another type of file

kore Files...

C:ADocuments and Settingshenordmas My Docum
C:ADocumentz and Settingzhenordmos by Docum
C:ADocuments and Settings‘enordmosiy Docum
C:ADocuments and Settingshenordmos by D ocum

[ ] Don't show this dislog in the future

ak. ] [ Cancel




Opening Screen:
The Data View

Pull-down
menus

i JRTANETL) S s SETa N IO \ __J\_.hjl
le i jew  Data Transform  Analyze  Graphs  Utilities  Add-ons  Window  Help
= [ = R i EHEER %@

| | | | variable
[ Cases }\ ‘” ﬁ ﬁ ﬁ j FEREE

Select tab
to switch
to Variable
View

Data values
appear here

Jh \;.I.!)ma\flew A variable View f



~ The Variable View

Variable view
contains information
about how each
variable is defined,

kcoded and displayed. D Same pull-
L down menus
o N
mti[!'ﬂd'l [ atasetl] S TS I it asiior \
File Edit ew Data Transform Analyze Graphs Uklities Add-ons  Window  Help
= 54 = B EE= = P = @
Marme Type | YWidth | Decimals | Label | Yalues Missing | Columns | Align | Measure |
4 ‘ ¢ \ f
: / | | / Level of \
: Num of .
Variable digits Descriptive label measurement:
names : that displays in scale (quant),
displayed )
output ordinal (ordered
: categorical, e.qg.,
How fjata sho_uld be N @ dEe e For example not er_nployed,
stored: numeric, date, places displayed 1=First Year, p_art—t|me, f_u||_
text string? 2=Sophomore, time), nominal

etc. \ (categorical) /




Working with the Data View

L BntitlediNDaiaseiD] S SPSs Datakditor

File Edit "."iE:'_.||'-.' Daka  Transform  Analyze  Graphs  Utlikies  Add-ons  Window  Help

= o i = EHd L % @

/2. To enter data in a cell, just click on it\
and start typing. Press ENTER when
finished and the next cell below is

l highlighted.

3. To edit a data value in a cell, click on
1. To change a it and either press DELETE and re-type
variable name, the correct value or double-click and

double-click and type. edit the value in place.

\ /




2. Getting data Into SPSS



Entering Data Manually:

An Example

See Example 1.1 of Moore’s
text for details about this
data.

-

Individual in household 346 weighs 91
pounds, is 27 years of age, travels 10

minutes to work, has completed some

college, and is female.

SERIALND| PWGTP |  AGEF Sy MNP SCHL | SEx |
1 255 187 55 5 1
2 253 158 56 g 2
3 323 176 54 10 12 2
4 345 339 37 10 11 1
| 345 91 7 10 10 7
,/’/’Eﬁ 370 234 53 10 13 1

Period
indicates
missing data.




Other Common Methods for
Getting Data into SPSS

 Method 1: Click on the data set name
(XXX .sav) from my website.

— Detalls are on the following pages.
« Method 2: Load an Excel spreadsheet file

— Variable names should be in the first row

— Use File...Open..Data in SPSS and locate the file
(set filetype to .x1Is).

— See me if you need more detalls.



Method 1.
Starting SPSS with Data
for a Problem from the Text (Table 1.5)

e (GO tO http://kzoo.edu/enordmoe/math260/spss/
e Click on the correct file name:

WMedne=sday, Lugust Z0, 2005 S:37 AM 839 ex27-43.sav
Medne=sday, Lugust 20, 2003 S:37 AM 1012 figd-Je.=zav
WMedne=sday, Lugust zZ0, 2003 S:37 AM 1145 figd-3m.=av
Mednesday, Lugust 20, 20038 S:37 AM 1567 tall-01.=sav
Mednesday, Lugust 20, 20053 S:37 AM 1595 tall-0:2.sav
Wednesday, hAugust Z0, 20053 S:37 LM 1625 tall-03.3av
Wednesday, hAugust Z0, 20053 S:37 LM 1619 !
Wednesday, hAugust Z0, 20053 S:37 LM ¢S tall-05.=av
Wednesday, Lugust 20, 2008 S:37 LM 1445
Wednesday, hAugust Z0, 20053 S:37 LM 1585 talzZ-02.3av
Wednesday, hAugust Z0, 20053 S:37 LM 1523 talzZ-03.s
WMedne=sday, Lugust 20, 2008 8:37 AM 1015 taDE—DQ.[%w
|
4 )
Click here to open SPSS
with the data from Table
Another Option is to 1.5 (you must be on a
I’ight-CliCk on the file Computer Wlth SPSS
name and the save the \_ -

file to be opened later.



http://kzoo.edu/enordmoe/math260/spss/

Method 1:
SPSS Data Set
Name Formats

e To access the class SPSS data sets,
remember these naming conventions:
—eg01-02 = Example 1.2
—ex01-11=>» Exercise 1.11
— fig4-3e =» Figure 4.3 (Eastern schools)
—ta01-01 = Table 1.1



Method 1 (cont’'d)
SPSS opens with the data
from Problem 1.35 pre-loaded

<2 a0 05 say ] Datasetd] - SPS5 Dataikditon Mi=1E3
File Edit Wiew Data Transform  Analyze Graphs  Ukilities  Add-ons  Window  Help
= W& A = & T EHER %@
1: co2 23
Ccoz vl | | Wl | Wal | Wl =l warl
3
2 38
3 17.0
3
5 1.8
B 16.0
= o These are the
g 1.4 required data for
ﬂ/ariab!e n,‘me\ B Problem 1.35
is loaded-With e (from Table 1.5).
the data-—Ygu -
may need to o
refer te—th%— 10.2
problem—tég = Note that the country names were not
kno_wwha%i:he s included in the dataset provided by the text.
varlab1e7 ?'3 You could add them manually if needed.
represeﬂtsﬁ / 3'8
18 36

+ » \DataView £ Variable View [

5P535 Processor is ready




3. Getting to know SPSS



The File Menu

iiled[Datasetd] S SPSsDatabdilor Ji=1/E3

Miegww Daka  Transform  Analvze  Graphs  Uklities  Add-ons  Window  Help

'h EE HEGE Y@

war | war | war | war war war war W

Chrl+F4
Chrl+-3

Save all Daka

Rename Datasek. ..
Display Data File Information »
Cache Data..,

4 R

This is a standard Windows
File menu used primarily to
open and save files.

Switch Server, .,

Recently Used Data »
Recently Used Files 3 K /
Exit

17

18

19

1 » \DataView A Variable View f
3PS5 Processar is ready




The Edit Menu

File: YWieww Data  Transform  &nal

/Use this menu for \ - .

manual editing of
t‘;hg S;;i;,et similar 104 Cu Ctrl+x  aba
spreadsheet (but you Copy Chrl+iC

cannot use
spreadsheet formulas —
in the SPSS Data

Q/iew. / —— lear Diel

Insert Yariable

Inserk Zases

Find... i_kr|+-F
o ko Case, .,

—  Oplions...
-\_-'l I 1arnraq



The Data Menu

NI e e | R T IR R R |

This menu
contains a couple

iImportant .
procedures for ! Transform  Analyze Graphs Lkl

preparing data for Osfine Variable Propertiss, ) = This can be done from

i = E he Variable Vi
further anal’y5|s T the Variable View
but we won’t use page.

it very often. Define Dates. .,
. Define Mulkiple Response Sets., ..

Use this or Right-click
on a variable name in
the Data View to sort
by a variable. TrEIrIEI:":lEE- “

Duplicake Cases,..

Restructure, ..
Merge Files »

Aggregate. ..

O )

Select cases that meet
a certain criterion
(e.g., females) or
select a random

ksample.

__| May be used towards
the end of the course.




The Transform Menu

Use to compute new

variables from ———

existing variables
(e.g., log(income)
from income).

\ ) J

We will seldom use of
the other commands
from this menu.

Analyze Graphs  Ukilities

Clamauts. D

/Change or combine \

categories (e.g.,
create binary
married/unmarried

CRecoe y+— r

Yisual Bander. ..

Countk. ..
Rank Cases...
Autormatic Recode. ..

Dake) Time, ..

_reate Time Series. ..

Feplace Missing Yalues...
Fandom Murnber Generators., ..

variable from a
general marital status
variable with several

Qategories). /




The Analyze Menu

KI'his menu contains the \
st_atlstlcal procedures we Graphs  Liklities
will learn (and many

more!). The ones we’ll use Reports
most are highlighted. . .
These are dgesc?ibed . Descriptive Skatiskics

Qietail in other help sheetSj _ompare Means

iaeneral Linear Model
Mixed Models
iZorrelake
Fegression

Loglinear

iZlassify

[raka Feduction
Scale

Monparametric Tests
Suryvival

b . . . T . . . . . . .

Mulkiple Response



The Graphs Menu

Kl'his menu contains the \

graphical procedures we
will learn (and many
more!). Again, the ones
we’ll use most are
highlighted. These are
described in detail in other

\help sheets. /

Lkilities  Add-ons

Zhart Builder...
Inkeractive 3

Bar...

3-D Bar...
Lime...
Area...

Pie. ..
High-Low, ..

Paretao...
Zontral. ..

Boxplok, ..
Error Bar...
Population Pyrarmid, . .

Scatter Dok,
Histogram...

P-P...

-0

Sequence...,

ROC Curve, ..

Time Series k



Other notes

« We will probably not use the Utilities and Add-
oNs menus.

e The Window menu Is similar to that in other
Windows software.

e Use F1 for general help or use the context-
specific help buttons in the dialog boxes.
— Until you get familiar with the program, you may have

difficulty making sense of the SPSS help. You may
ask me instead.



4. Creating a Histogram



Find and Open the Cars.sav data
set from my SPSS data directory

£ eavssav | Databetd || ESPSS D aiakditor ‘_J‘_Jh_/ﬂ

File m Wiewy Data Transform  Analyze Graphs  Utlities Add-ons  Window  Help

Bl o =k T BERE %9

1: mpgy 18

mpd engine |  horse | weight | accel | year | origin | cylinder | filter § |

1] 18 307 130 3504 12 70 1 g 0
2 15 350 | 165 | 3693 | 12| 70 1) 3| o
3 18 318 160 3436 11 70 1 g 0
4 16| 304 | 150 | 3433 12| 70/ 1 g 0|
5 17 | 302 | 140 | 3449 11| 70 1 g | 0|
B 18 479 195 4341 10 70 1 g 0
7 14| 454 | 220 | 4354 | 9| 70 1] g 0|
g 14| 440 | 215 | 4312 9| 70 1] g 0|
g 14| 455 | 225 | 4425 10/ 70 1 g | 0|

Click on the variable view
to get more information
about the variables from

the labels.



http://kzoo.edu/enordmoe/math260/spss/

Histogram of werght variable

tilities  Add-ons

Zhart Builder...
Interactive k

Bar...

3-D Bar...
Line...
Area, .,
Fie...
High-Low...

Pareto...
Cankral,..

Boxplot...
Errar Bar. ..
Population Pyramid. ..

1. Select Histogram from Scatter/Dot...
the Graphs menu "
Q-
Sequence. ..
RO Curve,,,

Time Series ]



Histogram dialog box

[ 2. Click OK to plot. ]

A x|
Wariable:

[ ] Dizplay normal curve

/
1. Highlight “Venhicle

Weight” and use the arrow
button to move it to the
\Variable box.

ﬁMiles per Gallan
{f Engine Dizplacement
ﬁ Horzepower [harze)
@? Time to Accelerate fro
S Model Year [modula 11 Panel by

é: Country of Origin [arigi ( Flows:
E[iNumI:uer af Cylinders [c B

,:[i cylrec =1 [ cylrec = 2|

Use these to get one <

histogram for each group / Columnz:
defined by another D
variable (e.g. Country)

\

Template | Titles.. |

[ ] Usze chart specifications from:

\%

3. Output viewer I
opens...




Output viewer: Histogram

40+

()
(=]
1

Frequency

)
[=]
1

10

=]

il

|
[ First look at the histogram. ]

Mean=2864 .56
Std. Dev. =849.827
=406

1000

I
2000 3000 4000 5000

Vehicle Weight (Ibs.)

G000

Let’'s see how to modify it to have fewer
bars and remove the legend at right. First
double-click on the plot.




Modifying a Histogram
In the Chart Editor

i |Ghart Editor =3
File Edit View Options Elements Transform  Help .
v MXYP =L ICEEL B E
sl Sansserit <l awe -|| B I | E = = || A-rI-—"
B G lia b |2 Bl |9
50+
7 Double click on bars
] to change the
N A1l number/width of | >
2™ bars
] |
=2
1]
ul: by —
20= . _
10 | .
Click and press
| .~3t':}?5g\f=.2=%ﬁg%%ﬁzr Del key to
) n HEiR remove the
o] 1000 2000 3000 4000 S000 G000 I e g e n d .
Vehicle Weight (Ibs.)
H:375, W 455 75 poirts




Changing the Histogram Bar Width

-

o

Set “Custom value” if

you want to be sure
the first bar starts at
a specific value on
the x-axis

~

)

0]

Use Custom “Bin
Sizes” to set the
number of intervals
r the Interval Width.

Chart Size | Fill & Border | Histogram Options |

Dizplay normal cure
Anchor First Bin

( Custormn walug far anchor:

Ein Sizes

Avtomatic

D
U=

/\Ne’ll set the interval\

width to be 250 Ibs
and anchor the first
bin at 500. In
practice, trial and
error with judgment

k IS needed. J

Cloze Help



Example: Changing the Histogram Bar Width

Chart Size | Fill & Border Histogram Options

Dizplay normal curye
Anchor First Bin

Automat]
First bar interval Custom walue for anchaor; [S00
starts at 500. -

Bin Sizes

Automatic

i

Murnber of interyvals:

Each bar spans 250
— erval wih:  [250

@ icancel Help



Example: After Modifying the Histogram

60

Frequency
e
]
|
I

[ Fewer, wider bars ]

20+

[ First bar starts at }

500.
: —’_L
0 | —i T I._

| |
0 1000 2000 3000 4000 5000 G000

Vehicle Weight (Ibs.)




Modifying the Histogram

Many other options exist for modifying plots in
the Chart Editor, too much to cover here.

Browse the menus or try double-clicking various
elements of the plot (scales, labels, etc.).

Ask If you have gquestions.

Note: To get percent rather than frequency on
the y-axis in SPSS v14, you need to use
Graphs...Interactive...Histogram.



Paneled Histogram

 To obtain a separate histogram for two or
more groups defined by a categorical
variable, carry out the procedure on the
next page.

« ODbtain a histogram of car weight for each
country of origin.



Paneled Histogram

&7 Miles per Gallon [mpa] W ariable: ok,
5‘5? E ngine Dizplacement | E ﬁVEhidE ‘wieight [Ibz.] [ue : _
é{? Horzepower [harze] B AR : _E_aste
&F Tiristo Acoalsiste fro R HEs oG & i [ Reset

8 Model ear [modulo 11

§ Mumber of Cylinders [ Fouws: Cancel

g culiec =1 [ cylrec =2 | @ Country of Origin [arigin] | Help |

| ezt variables [no ermpby rowes)

4 N

Move country
of Origin to
“Rows:” in the
“Panel by”

section.
N ot Tl

| Use chart specifications from:

Columnnhz:

]




Frequency

Paneled Histogram

-

The statistical
tendency for
American cars to be
much heavier is

| | readily seen.

~

T

| [

e
2000

i R e
3000 4000 S000

Vehicle Weight (Ibs.)

asauedep

ueadoing

uealIawy

uiBug Jo Aiaunon

One panel
for each
country.

f Note: Any \

cars missing
the value for
Country are
omitted
(including
the car with
weight under
1000 we saw

k before). /
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